fill in the kernel version info for every target, move the kernel tarball md5sums...
[openwrt-10.03/.git] / target / linux / magicbox-2.6 / Makefile
index 323eb2c3f4103b8cfc2e6af7356d1db94a166084..f80460fdd4f957330568961806bd54990c1655c4 100644 (file)
@@ -6,9 +6,16 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=powerpc
+BOARD:=magicbox
+BOARDNAME:=Magicbox
+FEATURES:=squashfs jffs2
+
+LINUX_VERSION:=2.6.21.5
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))