Further fix to 2.6.26 patch for USR8200
[openwrt-10.03/.git] / target / linux / ixp4xx / patches-2.6.26 / 500-usr8200_support.patch
index 7af0732258d0d6c701664715c1069168f575c731..137e7885aa94f50a86a3c006cfd99551f97c20d6 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/Kconfig
-===================================================================
---- linux-2.6.26.5.orig/arch/arm/mach-ixp4xx/Kconfig   2008-10-22 22:31:30.000000000 +0100
-+++ linux-2.6.26.5/arch/arm/mach-ixp4xx/Kconfig        2008-10-22 22:40:55.000000000 +0100
+--- a/arch/arm/mach-ixp4xx/Kconfig
++++ b/arch/arm/mach-ixp4xx/Kconfig
 @@ -97,6 +97,14 @@ config MACH_SIDEWINDER
          Engineering Sidewinder board. For more information on this
          platform, see http://www.adiengineering.com
@@ -17,10 +15,8 @@ Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/Kconfig
  config MACH_COMPEX
        bool "Compex WP18 / NP18A"
        select PCI
-Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/Makefile
-===================================================================
---- linux-2.6.26.5.orig/arch/arm/mach-ixp4xx/Makefile  2008-10-22 22:31:37.000000000 +0100
-+++ linux-2.6.26.5/arch/arm/mach-ixp4xx/Makefile       2008-10-22 22:49:38.000000000 +0100
+--- a/arch/arm/mach-ixp4xx/Makefile
++++ b/arch/arm/mach-ixp4xx/Makefile
 @@ -24,6 +24,7 @@ obj-pci-$(CONFIG_MACH_COMPEX)                += ixdp42
  obj-pci-$(CONFIG_MACH_WRT300NV2)              += wrt300nv2-pci.o
  obj-pci-$(CONFIG_MACH_AP1000)         += ixdp425-pci.o
@@ -37,11 +33,9 @@ Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/Makefile
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
  obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
-Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-pci.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-pci.c  2008-10-22 23:37:56.000000000 +0100
-@@ -0,0 +1,78 @@
+--- /dev/null
++++ b/arch/arm/mach-ixp4xx/usr8200-pci.c
+@@ -0,0 +1,79 @@
 +/*
 + * arch/arch/mach-ixp4xx/usr8200-pci.c
 + *
@@ -68,6 +62,7 @@ Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-pci.c
 +#include <linux/init.h>
 +#include <linux/irq.h>
 +
++#include <asm/irq.h>
 +#include <asm/mach-types.h>
 +#include <asm/hardware.h>
 +
@@ -75,11 +70,11 @@ Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-pci.c
 +
 +void __init usr8200_pci_preinit(void)
 +{
-+      set_irq_type(IRQ_IXP4XX_GPIO7, IRQT_LOW);
-+      set_irq_type(IRQ_IXP4XX_GPIO8, IRQT_LOW);
-+      set_irq_type(IRQ_IXP4XX_GPIO9, IRQT_LOW);
-+      set_irq_type(IRQ_IXP4XX_GPIO10, IRQT_LOW);
-+      set_irq_type(IRQ_IXP4XX_GPIO11, IRQT_LOW);
++      set_irq_type(IRQ_IXP4XX_GPIO7, IRQ_TYPE_LEVEL_LOW);
++      set_irq_type(IRQ_IXP4XX_GPIO8, IRQ_TYPE_LEVEL_LOW);
++      set_irq_type(IRQ_IXP4XX_GPIO9, IRQ_TYPE_LEVEL_LOW);
++      set_irq_type(IRQ_IXP4XX_GPIO10, IRQ_TYPE_LEVEL_LOW);
++      set_irq_type(IRQ_IXP4XX_GPIO11, IRQ_TYPE_LEVEL_LOW);
 +
 +      ixp4xx_pci_preinit();
 +}
@@ -120,11 +115,9 @@ Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-pci.c
 +}
 +
 +subsys_initcall(usr8200_pci_init);
-Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-setup.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-setup.c        2008-10-22 23:41:48.000000000 +0100
-@@ -0,0 +1,187 @@
+--- /dev/null
++++ b/arch/arm/mach-ixp4xx/usr8200-setup.c
+@@ -0,0 +1,211 @@
 +/*
 + * arch/arm/mach-ixp4xx/usr8200-setup.c
 + *
@@ -223,29 +216,35 @@ Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-setup.c
 +      .resource       = usr8200_uart_resources,
 +};
 +
-+/*
-+static struct i2c_gpio_platform_data usr8200_i2c_gpio_data = {
-+      .sda_pin        = 9,
-+      .scl_pin        = 10,
-+};
-+
-+static struct platform_device usr8200_i2c_gpio = {
-+      .name           = "i2c-gpio",
-+      .id             = 0,
-+      .dev            = {
-+              .platform_data  = &usr8200_i2c_gpio_data,
-+      },
-+};
-+
 +static struct gpio_led usr8200_led_pin[] = {
 +      {
-+              .name           = "usr8200:green:status",
-+              .gpio           = 7,
++              .name           = "usr8200:usb1",
++              .gpio           = 0,
++              .active_low     = 1,
++      },
++      {
++              .name           = "usr8200:usb2",
++              .gpio           = 1,
++              .active_low     = 1,
++      },
++      {
++              .name           = "usr8200:ieee1394",
++              .gpio           = 2,
++              .active_low     = 1,
++      },
++      {
++              .name           = "usr8200:internal",
++              .gpio           = 3,
++              .active_low     = 1,
++      },
++      {
++              .name           = "usr8200:power",
++              .gpio           = 14,
 +      }
 +};
 +
 +static struct gpio_led_platform_data usr8200_led_data = {
-+      .num_leds               = 1,
++      .num_leds               = ARRAY_SIZE(usr8200_led_pin),
 +      .leds                   = usr8200_led_pin,
 +};
 +
@@ -254,39 +253,49 @@ Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-setup.c
 +      .id                     = -1,
 +      .dev.platform_data      = &usr8200_led_data,
 +};
-+*/
 +
 +static struct eth_plat_info usr8200_plat_eth[] = {
-+      {
++      { /* NPEC - LAN with Marvell 88E6060 switch */
++              .phy            = IXP4XX_ETH_PHY_MAX_ADDR,
++              .phy_mask       = 0x0F0000,
++              .rxq            = 4,
++              .txreadyq       = 21,
++      }, { /* NPEB - WAN */
 +              .phy            = 9,
 +              .rxq            = 3,
 +              .txreadyq       = 20,
-+      }, {
-+              .phy            = 16,
-+              .rxq            = 4,
-+              .txreadyq       = 21,
 +      }
 +};
 +
 +static struct platform_device usr8200_eth[] = {
 +      {
 +              .name                   = "ixp4xx_eth",
-+              .id                     = IXP4XX_ETH_NPEB,
++              .id                     = IXP4XX_ETH_NPEC,
 +              .dev.platform_data      = usr8200_plat_eth,
 +      }, {
 +              .name                   = "ixp4xx_eth",
-+              .id                     = IXP4XX_ETH_NPEC,
++              .id                     = IXP4XX_ETH_NPEB,
 +              .dev.platform_data      = usr8200_plat_eth + 1,
 +      }
 +};
 +
++static struct resource usr8200_rtc_resources = {
++      .flags          = IORESOURCE_MEM
++};
++
++static struct platform_device usr8200_rtc = {
++      .name           = "rtc7301",
++      .id             = 0,
++      .resource       = &usr8200_rtc_resources,
++};
++
 +static struct platform_device *usr8200_devices[] __initdata = {
 +      &usr8200_flash,
 +      &usr8200_uart,
-+/*    &usr8200_led,
-+      &usr8200_i2c_gpio, */
++      &usr8200_led,
 +      &usr8200_eth[0],
 +      &usr8200_eth[1],
++      &usr8200_rtc,
 +};
 +
 +static void __init usr8200_init(void)
@@ -294,10 +303,18 @@ Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-setup.c
 +      ixp4xx_sys_init();
 +
 +      usr8200_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
-+      usr8200_flash_resource.end = IXP4XX_EXP_BUS_BASE(0) + SZ_64M - 1;
++      usr8200_flash_resource.end = IXP4XX_EXP_BUS_BASE(0) + SZ_16M - 1;
++
++      usr8200_rtc_resources.start = IXP4XX_EXP_BUS_BASE(2);
++      usr8200_rtc_resources.end = IXP4XX_EXP_BUS_BASE(2) + 0x01ff;
 +
 +      *IXP4XX_EXP_CS0 |= IXP4XX_FLASH_WRITABLE;
-+      *IXP4XX_EXP_CS1 = *IXP4XX_EXP_CS0;
++      *IXP4XX_EXP_CS2 = IXP4XX_EXP_BUS_SIZE(0) | IXP4XX_EXP_BUS_WR_EN |
++                        IXP4XX_EXP_BUS_CS_EN | IXP4XX_EXP_BUS_BYTE_EN;
++      *IXP4XX_GPIO_GPCLKR = 0x01100000;
++
++      /* configure button as input */
++      gpio_line_config(12, IXP4XX_GPIO_IN);
 +
 +      platform_add_devices(usr8200_devices, ARRAY_SIZE(usr8200_devices));
 +}
@@ -312,10 +329,8 @@ Index: linux-2.6.26.5/arch/arm/mach-ixp4xx/usr8200-setup.c
 +      .boot_params    = 0x0100,
 +      .init_machine   = usr8200_init,
 +MACHINE_END
-Index: linux-2.6.26.5/include/asm-arm/arch-ixp4xx/uncompress.h
-===================================================================
---- linux-2.6.26.5.orig/include/asm-arm/arch-ixp4xx/uncompress.h       2008-10-22 23:27:33.000000000 +0100
-+++ linux-2.6.26.5/include/asm-arm/arch-ixp4xx/uncompress.h    2008-10-22 23:28:09.000000000 +0100
+--- a/include/asm-arm/arch-ixp4xx/uncompress.h
++++ b/include/asm-arm/arch-ixp4xx/uncompress.h
 @@ -43,7 +43,7 @@ static __inline__ void __arch_decomp_set
        if (machine_is_adi_coyote() || machine_is_gtwx5715() ||
                         machine_is_gateway7001() || machine_is_wg302v2() ||