ixp4xx/fsg3: Fix board code detection of the RTC chip
[openwrt-10.03/.git] / target / linux / ixp4xx / patches-2.6.26 / 030-ixp4xx_fsg_board_support.patch
index 8fb7280e079bca32e8d88967840d37f727414556..1707cff69713f49289d957a8a2557c7262d04c96 100644 (file)
@@ -1,53 +1,6 @@
-From: Rod Whitby <rod@whitby.id.au>
-Subject: [PATCH] ixp4xx: Add support for the Freecom FSG-3 board (Patch #4874)
-
-The Freecom-FSG3 is a small network-attached-storage device with the
-following feature set:
-
-* Intel IXP422
-* 4MB Flash (ixp4xx flash driver)
-* 64MB RAM
-* 4 USB 2.0 host ports (ehci and ohci drivers)
-* 1 WAN (eth1) and 3 LAN (eth0) ethernet ports
-  * Supported by the open source ixp4xx ethernet driver
-* Via VT6421 disk controller (libata and sata-via drivers)
-  * Internal hard disk (PATA supported, SATA not yet supported)
-  * External SATA port (not yet supported)
-* ISL1208 RTC chip
-* Winbond 83782 temp sensor and fan controller
-* MiniPCI slot
-
-The ixp4xx_defconfig is also updated to support this device (the
-leds-fsg driver is to be submitted separately via the leds tree after
-this initial support is merged, as it depends on header gpio defines).
-
-Signed-off-by: Rod Whitby <rod@whitby.id.au>
-
-PATCH FOLLOWS
-KernelVersion: v2.6.25-rc6-74-g264e3e8
----
-
-Updated to correct all issues found by RMK.
-
-The front power button calls ctrl_alt_del() and the rear reset button
-now calls machine_restart() directly.
-
- arch/arm/configs/ixp4xx_defconfig      |    9 +-
- arch/arm/mach-ixp4xx/Kconfig           |    9 +
- arch/arm/mach-ixp4xx/Makefile          |    2 +
- arch/arm/mach-ixp4xx/fsg-pci.c         |   71 ++++++++
- arch/arm/mach-ixp4xx/fsg-setup.c       |  276 ++++++++++++++++++++++++++++++++
- include/asm-arm/arch-ixp4xx/fsg.h      |   50 ++++++
- include/asm-arm/arch-ixp4xx/hardware.h |    1 +
- include/asm-arm/arch-ixp4xx/irqs.h     |    7 +
- 8 files changed, 421 insertions(+), 4 deletions(-)
- create mode 100644 arch/arm/mach-ixp4xx/fsg-pci.c
- create mode 100644 arch/arm/mach-ixp4xx/fsg-setup.c
- create mode 100644 include/asm-arm/arch-ixp4xx/fsg.h
-
 --- a/arch/arm/configs/ixp4xx_defconfig
 +++ b/arch/arm/configs/ixp4xx_defconfig
-@@ -165,6 +165,7 @@
+@@ -165,6 +165,7 @@ CONFIG_ARCH_PRPMC1100=y
  CONFIG_MACH_NAS100D=y
  CONFIG_MACH_DSMG600=y
  CONFIG_ARCH_IXDP4XX=y
@@ -55,7 +8,7 @@ now calls machine_restart() directly.
  CONFIG_CPU_IXP46X=y
  CONFIG_CPU_IXP43X=y
  CONFIG_MACH_GTWX5715=y
-@@ -770,7 +771,7 @@
+@@ -770,7 +771,7 @@ CONFIG_ATA=y
  # CONFIG_SATA_SIL24 is not set
  # CONFIG_SATA_SIS is not set
  # CONFIG_SATA_ULI is not set
@@ -64,7 +17,7 @@ now calls machine_restart() directly.
  # CONFIG_SATA_VITESSE is not set
  # CONFIG_SATA_INIC162X is not set
  # CONFIG_PATA_ALI is not set
-@@ -1143,7 +1144,7 @@
+@@ -1143,7 +1144,7 @@ CONFIG_HWMON=y
  # CONFIG_SENSORS_VIA686A is not set
  # CONFIG_SENSORS_VT1211 is not set
  # CONFIG_SENSORS_VT8231 is not set
@@ -73,7 +26,7 @@ now calls machine_restart() directly.
  # CONFIG_SENSORS_W83791D is not set
  # CONFIG_SENSORS_W83792D is not set
  # CONFIG_SENSORS_W83793 is not set
-@@ -1334,8 +1335,8 @@
+@@ -1334,8 +1335,8 @@ CONFIG_LEDS_CLASS=y
  #
  # LED drivers
  #
@@ -83,7 +36,7 @@ now calls machine_restart() directly.
  
  #
  # LED Triggers
-@@ -1367,7 +1368,7 @@
+@@ -1367,7 +1368,7 @@ CONFIG_RTC_INTF_DEV=y
  # CONFIG_RTC_DRV_DS1672 is not set
  # CONFIG_RTC_DRV_MAX6900 is not set
  # CONFIG_RTC_DRV_RS5C372 is not set
@@ -94,7 +47,7 @@ now calls machine_restart() directly.
  # CONFIG_RTC_DRV_PCF8583 is not set
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -125,6 +125,15 @@
+@@ -125,6 +125,15 @@ config    ARCH_IXDP4XX
        depends on ARCH_IXDP425 || MACH_IXDP465 || MACH_KIXRP435
        default y
  
@@ -112,7 +65,7 @@ now calls machine_restart() directly.
  #
 --- a/arch/arm/mach-ixp4xx/Makefile
 +++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -15,6 +15,7 @@
+@@ -15,6 +15,7 @@ obj-pci-$(CONFIG_MACH_NAS100D)               += nas10
  obj-pci-$(CONFIG_MACH_DSMG600)                += dsmg600-pci.o
  obj-pci-$(CONFIG_MACH_GATEWAY7001)    += gateway7001-pci.o
  obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
@@ -120,7 +73,7 @@ now calls machine_restart() directly.
  
  obj-y += common.o
  
-@@ -28,6 +29,7 @@
+@@ -28,6 +29,7 @@ obj-$(CONFIG_MACH_NAS100D)   += nas100d-se
  obj-$(CONFIG_MACH_DSMG600)      += dsmg600-setup.o
  obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
  obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
@@ -271,7 +224,7 @@ now calls machine_restart() directly.
 +
 +static struct i2c_board_info __initdata fsg_i2c_board_info [] = {
 +      {
-+              I2C_BOARD_INFO("rtc-isl1208", 0x6f),
++              I2C_BOARD_INFO("isl1208", 0x6f),
 +      },
 +};
 +