target/linux/image rewrite
[openwrt-10.03/.git] / target / linux / image / squashfs.mk
index 184330cfe7276d70db689337e7cde79f370a162f..6890daec680b5df6ce9e854fc4f67b69af5d6760 100644 (file)
@@ -1,36 +1,22 @@
 ifneq ($(CONFIG_BIG_ENDIAN),y)
-endian := le
+ENDIAN := le
 else
-endian := be
+ENDIAN := be
 endif
 
-squashfs-prepare: FORCE
-       $(MAKE) -C squashfs prepare
-
-squashfs-compile: prepare-targets
-       $(MAKE) -C squashfs compile
+$(STAGING_DIR)/bin/mksquashfs-lzma:
+       $(MAKE) -C $(TOPDIR)/target/linux/image/squashfs compile
        
 squashfs-clean: FORCE
-       $(MAKE) -C squashfs clean
+       $(MAKE) -C $(TOPDIR)/target/linux/image/squashfs clean
        rm -f $(KDIR)/root.squashfs
 
-$(KDIR)/root.squashfs: install-prepare
+define Image/mkfs/squashfs
        @mkdir -p $(BUILD_DIR)/root/jffs
-       $(STAGING_DIR)/bin/mksquashfs-lzma $(BUILD_DIR)/root $@ -nopad -noappend -root-owned -$(endian)
-       
-ifeq ($(IB),)
-squashfs-install: compile-targets $(BOARD)-compile
-endif
+       $(STAGING_DIR)/bin/mksquashfs-lzma $(BUILD_DIR)/root $(KDIR)/root.squashfs -nopad -noappend -root-owned -$(ENDIAN)
+       $(call Image/Build,squashfs)
+endef
 
-squashfs-install: $(KDIR)/root.squashfs FORCE
-       $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"
-
-squashfs-install-ib: compile-targets
-       mkdir -p $(IB_DIR)/staging_dir_$(ARCH)/bin
-       $(CP) $(STAGING_DIR)/bin/mksquashfs-lzma $(IB_DIR)/staging_dir_$(ARCH)/bin
-       
-prepare-targets: squashfs-prepare
-compile-targets: squashfs-compile
-install-targets: squashfs-install
-install-ib: squashfs-install-ib
-clean: squashfs-clean
+FILESYSTEMS += squashfs
+compile-targets: $(STAGING_DIR)/bin/mksquashfs-lzma
+clean-targets: squashfs-clean