fix annoying make parse error
[openwrt-10.03/.git] / target / linux / image / aruba / Makefile
index 835de1bef4a6242eeae1c45c2dd7ac5a45d1bd0b..d68084b26161abad66c38da1245e7ba8591f5e6e 100644 (file)
@@ -16,19 +16,20 @@ endef
 
 define Image/Prepare
        cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-       $(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) compile
+       $(MAKE) -C ../generic/lzma-loader $(LOADER_MAKEOPTS) clean compile
 endef
 
-define Image/Build
+define Image/BuildKernel
        ./addVersion -n ArubaOS $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari version
-ifneq ($(CONFIG_ARUBA_RAMDISK),y)
+endef
+
 ifeq ($(1),jffs2-64k)
-endif
+define Image/Build
        @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=655360 conv=sync
        @cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
        @dd if=$(KDIR)/image.tmp of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1)).bin bs=3604480 conv=sync
        @rm -f $(KDIR)/image.tmp
-endif
 endef
+endif
 
 $(eval $(call BuildImage))