Add a toggle for ramdisk support
[openwrt-10.03/.git] / target / linux / image / aruba / Makefile
index 59bf59777b81dabf0db8dcc4b3d2e2e0419ae248..432a85d59e2a492d8362b3f7607468ae8a9717e4 100644 (file)
@@ -26,6 +26,16 @@ ifeq ($(FS),jffs2-4MB)
 $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari: $(KDIR)/loader.elf
        ./addVersion -n ArubaOS $(KDIR)/loader.elf $@ version
 
+ifneq ($(BR2_ARUBA_RAMDISK),y)
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari $(KDIR)/root.$(FS)
+       @dd if=$< of=$@.tmp bs=655360 conv=sync
+       @cat $(KDIR)/root.$(FS) >> $@.tmp
+       @dd if=$@.tmp of=$@ bs=3604480 conv=sync
+       @rm -f $@.tmp
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FSNAME).bin
+endif
+
 install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari
 endif
 endif