refresh 2.6.30 patches
[openwrt-10.03/.git] / target / linux / generic-2.6 / patches-2.6.30 / 020-mips_multi_machine_support.patch
index 28cc14931cb8587479a573c8e1c5e0eabe89f349..6ff7504dd30bb78b9db9b91295eb4482caf98a39 100644 (file)
@@ -1,5 +1,5 @@
 --- /dev/null
-+++ b/include/asm-mips/mips_machine.h
++++ b/arch/mips/include/asm/mips_machine.h
 @@ -0,0 +1,47 @@
 +/*
 + *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
 +}
 --- a/arch/mips/kernel/Makefile
 +++ b/arch/mips/kernel/Makefile
-@@ -85,6 +85,7 @@
+@@ -85,6 +85,7 @@ obj-$(CONFIG_GPIO_TXX9)              += gpio_txx9.o
  
  obj-$(CONFIG_KEXEC)           += machine_kexec.o relocate_kernel.o
  obj-$(CONFIG_EARLY_PRINTK)    += early_printk.o
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -803,6 +803,9 @@
+@@ -803,6 +803,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
  config SYNC_R4K
        bool
  
  
  unsigned int vced_count, vcei_count;
  
-@@ -33,8 +34,12 @@
+@@ -33,8 +34,12 @@ static int show_cpuinfo(struct seq_file
        /*
         * For the first processor also print the system type
         */