[kernel] update to 2.6.28.5
[openwrt-10.03/.git] / target / linux / generic-2.6 / patches-2.6.28 / 921-gpio_spi_driver.patch
index d55eda6355089f752b7c0b6352ee5683845050fa..98b764d6f810583b8c9908d7324975e7bd3f6f20 100644 (file)
@@ -1,5 +1,13 @@
+THIS CODE IS DEPRECATED.
+
+Please use the new mainline SPI-GPIO driver, as of 2.6.29.
+
+--mb
+
+
+
 --- /dev/null
-+++ b/include/linux/spi/spi_gpio.h
++++ b/include/linux/spi/spi_gpio_old.h
 @@ -0,0 +1,73 @@
 +/*
 + * spi_gpio interface to platform code
@@ -75,7 +83,7 @@
 +
 +#endif /* _LINUX_SPI_SPI_GPIO */
 --- /dev/null
-+++ b/drivers/spi/spi_gpio.c
++++ b/drivers/spi/spi_gpio_old.c
 @@ -0,0 +1,251 @@
 +/*
 + * Bitbanging SPI bus driver using GPIO API
 +#include <linux/platform_device.h>
 +#include <linux/spi/spi.h>
 +#include <linux/spi/spi_bitbang.h>
-+#include <linux/spi/spi_gpio.h>
++#include <linux/spi/spi_gpio_old.h>
 +#include <linux/gpio.h>
 +#include <asm/atomic.h>
 +
 +MODULE_LICENSE("GPL v2");
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -100,6 +100,19 @@ config SPI_BUTTERFLY
-         inexpensive battery powered microcontroller evaluation board.
-         This same cable can be used to flash new firmware.
+@@ -116,6 +116,15 @@ config SPI_GPIO
+         GPIO operations, you should be able to leverage that for better
+         speed with a custom version of this driver; see the source code.
  
-+config SPI_GPIO
-+      tristate "GPIO API based bitbanging SPI controller"
++config SPI_GPIO_OLD
++      tristate "Old GPIO API based bitbanging SPI controller (DEPRECATED)"
 +      depends on SPI_MASTER && GENERIC_GPIO
 +      select SPI_BITBANG
 +      help
-+        This is a platform driver that can be used for bitbanging
-+        an SPI bus over GPIO pins.
-+        Select this if you have any SPI device that is connected via
-+        GPIO pins.
-+        The module will be called spi_gpio.
++        This code is deprecated. Please use the new mainline SPI-GPIO driver.
 +
 +        If unsure, say N.
 +
        depends on ARCH_IMX && EXPERIMENTAL
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN)                       += spi_bfin5xx.
- obj-$(CONFIG_SPI_BITBANG)             += spi_bitbang.o
+@@ -17,6 +17,7 @@ obj-$(CONFIG_SPI_BITBANG)            += spi_bitban
  obj-$(CONFIG_SPI_AU1550)              += au1550_spi.o
  obj-$(CONFIG_SPI_BUTTERFLY)           += spi_butterfly.o
-+obj-$(CONFIG_SPI_GPIO)                        += spi_gpio.o
+ obj-$(CONFIG_SPI_GPIO)                        += spi_gpio.o
++obj-$(CONFIG_SPI_GPIO_OLD)            += spi_gpio_old.o
  obj-$(CONFIG_SPI_IMX)                 += spi_imx.o
  obj-$(CONFIG_SPI_LM70_LLP)            += spi_lm70llp.o
  obj-$(CONFIG_SPI_PXA2XX)              += pxa2xx_spi.o
---- a/MAINTAINERS
-+++ b/MAINTAINERS
-@@ -4017,6 +4017,11 @@ M:      jbglaw@lug-owl.de
- L:    linux-kernel@vger.kernel.org
- S:    Maintained
-+SPI GPIO MASTER DRIVER
-+P:    Michael Buesch
-+M:    mb@bu3sch.de
-+S:    Maintained
-+
- STABLE BRANCH
- P:    Greg Kroah-Hartman
- M:    greg@kroah.com