Make lzma-loader sdram mapping configurable (#1169)
[openwrt-10.03/.git] / target / linux / generic-2.6 / image / lzma-loader / src / Makefile
index dbe9019f2bd1490391b740ac1d1b974ab68d4745..13ed96213e6ba557166766ee91c5eee9b94a7b05 100644 (file)
@@ -4,15 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+RAMSTART = 0x80000000
+RAMSIZE = 0x00100000           # 1MB
 LOADADDR = 0x80400000          # RAM start + 4M
 KERNEL_ENTRY = 0x80001000
-RAMSIZE = 0x00100000           # 1MB
 IMAGE_COPY:=0
 
 CROSS_COMPILE = mips-linux-
 
 OBJCOPY:= $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
-CFLAGS := -fno-builtin -Os -G 0 -ffunction-sections -mno-abicalls -fno-pic -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -Wall -DRAMSIZE=${RAMSIZE} -DKERNEL_ENTRY=${KERNEL_ENTRY} -D_LZMA_IN_CB
+CFLAGS := -fno-builtin -Os -G 0 -ffunction-sections -mno-abicalls -fno-pic -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap -Wall -DRAMSTART=${RAMSTART} -DRAMSIZE=${RAMSIZE} -DKERNEL_ENTRY=${KERNEL_ENTRY} -D_LZMA_IN_CB
 ifeq ($(IMAGE_COPY),1)
 CFLAGS += -DLOADADDR=${LOADADDR} -DIMAGE_COPY=1
 endif