get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt-10.03/.git] / target / linux / generic-2.6 / image / lzma-loader / Makefile
index e3a98afbce0dd70f055c8aa56683aaa51ee49d3e..d75a4468b0b40617667413c695bc1f847a3c2f00 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 1823 2005-09-01 20:07:42Z nbd $
 
 include $(TOPDIR)/rules.mk
 
@@ -33,11 +32,15 @@ $(PKG_BUILD_DIR)/vmlinux.lzma: $(KDIR)/vmlinux.lzma
 $(KDIR)/loader$(LOADER_TYPE).elf: $(PKG_BUILD_DIR)/lzma.elf
        $(CP) $< $@
 
+$(KDIR)/loader$(LOADER_TYPE).bin: $(PKG_BUILD_DIR)/lzma.bin
+       $(CP) $< $@
+
 download: 
 prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(KDIR)/loader$(LOADER_TYPE).elf
+compile: $(KDIR)/loader$(LOADER_TYPE).elf $(KDIR)/loader$(LOADER_TYPE).bin
 install:
 
 clean:
        rm -rf $(PKG_BUILD_DIR)
        rm -f $(KDIR)/loader.elf
+       rm -f $(KDIR)/loader.bin