split out profile definitions from Makefiles
[openwrt-10.03/.git] / target / linux / brcm63xx-2.6 / Makefile
index b9fd03c9e7fcf10912c5f1d1463ff711772be0a1..81a40d93e6a878e3c00b9b0fc7852a1d999f14c8 100644 (file)
@@ -18,22 +18,7 @@ endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Broadcom
-  NAME:=Broadcom WiFi (default)
-  PACKAGES:=kmod-net-bcm43xx
-endef
-$(eval $(call Profile,Broadcom))
-
-define Profile/Atheros
-  NAME:=Atheros WiFi
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/Ralink
-  NAME:=Ralink WiFi
-  PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))