cleanup/rewrite of the kernel build process
[openwrt-10.03/.git] / target / linux / brcm63xx-2.6 / Makefile
index a48442a69f3fd8bd47c6d15cd263f2c6d6aeb19c..323eb2c3f4103b8cfc2e6af7356d1db94a166084 100644 (file)
@@ -1,18 +1,14 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.8.1
+LINUX_VERSION:=2.6.17
 LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=9517ca999e822b898fbdc7e72796b1aa
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/kernel-build.mk
-
-
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       #[ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
-       @$(CP) config $(LINUX_DIR)/.config
-       @$(CP) ./files/built-in.o $(LINUX_DIR)/bcmdrivers/broadcom/
-       touch $@
-
+$(eval $(call BuildKernel))