SSB-GigE: Fix IRQ routing. This makes the device work. Yay! :)
[openwrt-10.03/.git] / target / linux / brcm47xx / patches-2.6.23 / 700-ssb-gigabit-ethernet-driver.patch
index 2b31d6912418a89a8dffedb26d7939061189c2a2..90346e289ee9fa0b08011cca2cb26b6920bad198 100644 (file)
@@ -31,8 +31,8 @@ Index: linux-2.6.23.16/drivers/ssb/Makefile
 Index: linux-2.6.23.16/drivers/ssb/driver_gige.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23.16/drivers/ssb/driver_gige.c  2008-02-22 20:59:46.000000000 +0100
-@@ -0,0 +1,281 @@
++++ linux-2.6.23.16/drivers/ssb/driver_gige.c  2008-02-28 12:26:18.000000000 +0100
+@@ -0,0 +1,286 @@
 +/*
 + * Sonics Silicon Backplane
 + * Broadcom Gigabit Ethernet core driver
@@ -49,16 +49,17 @@ Index: linux-2.6.23.16/drivers/ssb/driver_gige.c
 +#include <linux/ssb/ssb_driver_gige.h>
 +
 +
++/*
 +MODULE_DESCRIPTION("SSB Broadcom Gigabit Ethernet driver");
 +MODULE_AUTHOR("Michael Buesch");
 +MODULE_LICENSE("GPL");
-+
++*/
 +
 +static const struct ssb_device_id ssb_gige_tbl[] = {
 +      SSB_DEVICE(SSB_VENDOR_BROADCOM, SSB_DEV_ETHERNET_GBIT, SSB_ANY_REV),
 +      SSB_DEVTABLE_END
 +};
-+MODULE_DEVICE_TABLE(ssb, ssb_gige_tbl);
++/* MODULE_DEVICE_TABLE(ssb, ssb_gige_tbl); */
 +
 +
 +static inline u8 gige_read8(struct ssb_gige *dev, u16 offset)
@@ -288,6 +289,10 @@ Index: linux-2.6.23.16/drivers/ssb/driver_gige.c
 +      res->start = dev->mem_resource.start;
 +      res->end = dev->mem_resource.end;
 +
++      /* Fixup interrupt lines. */
++      pdev->irq = ssb_mips_irq(sdev) + 2;
++      pci_write_config_byte(pdev, PCI_INTERRUPT_LINE, pdev->irq);
++
 +      return 0;
 +}
 +
@@ -912,7 +917,7 @@ Index: linux-2.6.23.16/drivers/ssb/ssb_private.h
 Index: linux-2.6.23.16/drivers/net/tg3.c
 ===================================================================
 --- linux-2.6.23.16.orig/drivers/net/tg3.c     2008-02-22 19:40:57.000000000 +0100
-+++ linux-2.6.23.16/drivers/net/tg3.c  2008-02-23 20:02:58.000000000 +0100
++++ linux-2.6.23.16/drivers/net/tg3.c  2008-02-28 12:28:17.000000000 +0100
 @@ -38,6 +38,7 @@
  #include <linux/workqueue.h>
  #include <linux/prefetch.h>
@@ -933,7 +938,60 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
                tp->read32_mbox(tp, off);
  }
  
-@@ -1988,6 +1990,14 @@ static int tg3_setup_copper_phy(struct t
+@@ -623,7 +625,7 @@ static void tg3_switch_clocks(struct tg3
+ #define PHY_BUSY_LOOPS        5000
+-static int tg3_readphy(struct tg3 *tp, int reg, u32 *val)
++static int __tg3_readphy(struct tg3 *tp, unsigned int phy_addr, int reg, u32 *val)
+ {
+       u32 frame_val;
+       unsigned int loops;
+@@ -637,7 +639,7 @@ static int tg3_readphy(struct tg3 *tp, i
+       *val = 0x0;
+-      frame_val  = ((PHY_ADDR << MI_COM_PHY_ADDR_SHIFT) &
++      frame_val  = ((phy_addr << MI_COM_PHY_ADDR_SHIFT) &
+                     MI_COM_PHY_ADDR_MASK);
+       frame_val |= ((reg << MI_COM_REG_ADDR_SHIFT) &
+                     MI_COM_REG_ADDR_MASK);
+@@ -672,7 +674,12 @@ static int tg3_readphy(struct tg3 *tp, i
+       return ret;
+ }
+-static int tg3_writephy(struct tg3 *tp, int reg, u32 val)
++static int tg3_readphy(struct tg3 *tp, int reg, u32 *val)
++{
++      return __tg3_readphy(tp, PHY_ADDR, reg, val);
++}
++
++static int __tg3_writephy(struct tg3 *tp, unsigned int phy_addr, int reg, u32 val)
+ {
+       u32 frame_val;
+       unsigned int loops;
+@@ -688,7 +695,7 @@ static int tg3_writephy(struct tg3 *tp, 
+               udelay(80);
+       }
+-      frame_val  = ((PHY_ADDR << MI_COM_PHY_ADDR_SHIFT) &
++      frame_val  = ((phy_addr << MI_COM_PHY_ADDR_SHIFT) &
+                     MI_COM_PHY_ADDR_MASK);
+       frame_val |= ((reg << MI_COM_REG_ADDR_SHIFT) &
+                     MI_COM_REG_ADDR_MASK);
+@@ -721,6 +728,11 @@ static int tg3_writephy(struct tg3 *tp, 
+       return ret;
+ }
++static int tg3_writephy(struct tg3 *tp, int reg, u32 val)
++{
++      return __tg3_writephy(tp, PHY_ADDR, reg, val);
++}
++
+ static void tg3_phy_toggle_automdix(struct tg3 *tp, int enable)
+ {
+       u32 phy;
+@@ -1988,6 +2000,14 @@ static int tg3_setup_copper_phy(struct t
                tp->link_config.active_duplex = current_duplex;
        }
  
@@ -948,7 +1006,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (current_link_up == 1 &&
            (tp->link_config.active_duplex == DUPLEX_FULL) &&
            (tp->link_config.autoneg == AUTONEG_ENABLE)) {
-@@ -4813,6 +4823,11 @@ static int tg3_poll_fw(struct tg3 *tp)
+@@ -4813,6 +4833,11 @@ static int tg3_poll_fw(struct tg3 *tp)
        int i;
        u32 val;
  
@@ -960,7 +1018,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5906) {
                /* Wait up to 20ms for init done. */
                for (i = 0; i < 200; i++) {
-@@ -5040,6 +5055,14 @@ static int tg3_chip_reset(struct tg3 *tp
+@@ -5040,6 +5065,14 @@ static int tg3_chip_reset(struct tg3 *tp
                tw32(0x5000, 0x400);
        }
  
@@ -975,7 +1033,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        tw32(GRC_MODE, tp->grc_mode);
  
        if (tp->pci_chip_rev_id == CHIPREV_ID_5705_A0) {
-@@ -5308,9 +5331,12 @@ static int tg3_halt_cpu(struct tg3 *tp, 
+@@ -5308,9 +5341,12 @@ static int tg3_halt_cpu(struct tg3 *tp, 
                return -ENODEV;
        }
  
@@ -991,7 +1049,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        return 0;
  }
  
-@@ -5391,6 +5417,11 @@ static int tg3_load_5701_a0_firmware_fix
+@@ -5391,6 +5427,11 @@ static int tg3_load_5701_a0_firmware_fix
        struct fw_info info;
        int err, i;
  
@@ -1003,7 +1061,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        info.text_base = TG3_FW_TEXT_ADDR;
        info.text_len = TG3_FW_TEXT_LEN;
        info.text_data = &tg3FwText[0];
-@@ -5949,6 +5980,11 @@ static int tg3_load_tso_firmware(struct 
+@@ -5949,6 +5990,11 @@ static int tg3_load_tso_firmware(struct 
        unsigned long cpu_base, cpu_scratch_base, cpu_scratch_size;
        int err, i;
  
@@ -1015,7 +1073,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (tp->tg3_flags2 & TG3_FLG2_HW_TSO)
                return 0;
  
-@@ -6850,6 +6886,11 @@ static void tg3_timer(unsigned long __op
+@@ -6850,6 +6896,11 @@ static void tg3_timer(unsigned long __op
  
        spin_lock(&tp->lock);
  
@@ -1027,7 +1085,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (!(tp->tg3_flags & TG3_FLAG_TAGGED_STATUS)) {
                /* All of this garbage is because when using non-tagged
                 * IRQ status the mailbox/status_block protocol the chip
-@@ -8432,6 +8473,11 @@ static int tg3_test_nvram(struct tg3 *tp
+@@ -8432,6 +8483,11 @@ static int tg3_test_nvram(struct tg3 *tp
        u32 *buf, csum, magic;
        int i, j, err = 0, size;
  
@@ -1039,7 +1097,25 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (tg3_nvram_read_swab(tp, 0, &magic) != 0)
                return -EIO;
  
-@@ -9571,6 +9617,12 @@ static void __devinit tg3_get_5906_nvram
+@@ -9154,7 +9210,7 @@ static int tg3_ioctl(struct net_device *
+                       return -EAGAIN;
+               spin_lock_bh(&tp->lock);
+-              err = tg3_readphy(tp, data->reg_num & 0x1f, &mii_regval);
++              err = __tg3_readphy(tp, data->phy_id & 0x1f, data->reg_num & 0x1f, &mii_regval);
+               spin_unlock_bh(&tp->lock);
+               data->val_out = mii_regval;
+@@ -9173,7 +9229,7 @@ static int tg3_ioctl(struct net_device *
+                       return -EAGAIN;
+               spin_lock_bh(&tp->lock);
+-              err = tg3_writephy(tp, data->reg_num & 0x1f, data->val_in);
++              err = __tg3_writephy(tp, data->phy_id & 0x1f, data->reg_num & 0x1f, data->val_in);
+               spin_unlock_bh(&tp->lock);
+               return err;
+@@ -9571,6 +9627,12 @@ static void __devinit tg3_get_5906_nvram
  /* Chips other than 5700/5701 use the NVRAM for fetching info. */
  static void __devinit tg3_nvram_init(struct tg3 *tp)
  {
@@ -1052,7 +1128,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        tw32_f(GRC_EEPROM_ADDR,
             (EEPROM_ADDR_FSM_RESET |
              (EEPROM_DEFAULT_CLOCK_PERIOD <<
-@@ -9706,6 +9758,9 @@ static int tg3_nvram_read(struct tg3 *tp
+@@ -9706,6 +9768,9 @@ static int tg3_nvram_read(struct tg3 *tp
  {
        int ret;
  
@@ -1062,7 +1138,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (!(tp->tg3_flags & TG3_FLAG_NVRAM))
                return tg3_nvram_read_using_eeprom(tp, offset, val);
  
-@@ -9938,6 +9993,9 @@ static int tg3_nvram_write_block(struct 
+@@ -9938,6 +10003,9 @@ static int tg3_nvram_write_block(struct 
  {
        int ret;
  
@@ -1072,7 +1148,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if (tp->tg3_flags & TG3_FLAG_EEPROM_WRITE_PROT) {
                tw32_f(GRC_LOCAL_CTRL, tp->grc_local_ctrl &
                       ~GRC_LCLCTRL_GPIO_OUTPUT1);
-@@ -10804,7 +10862,6 @@ static int __devinit tg3_get_invariants(
+@@ -10804,7 +10872,6 @@ static int __devinit tg3_get_invariants(
                tp->write32 = tg3_write_flush_reg32;
        }
  
@@ -1080,7 +1156,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        if ((tp->tg3_flags & TG3_FLAG_TXD_MBOX_HWBUG) ||
            (tp->tg3_flags & TG3_FLAG_MBOX_WRITE_REORDER)) {
                tp->write32_tx_mbox = tg3_write32_tx_mbox;
-@@ -10840,6 +10897,11 @@ static int __devinit tg3_get_invariants(
+@@ -10840,6 +10907,11 @@ static int __devinit tg3_get_invariants(
              GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5701)))
                tp->tg3_flags |= TG3_FLAG_SRAM_USE_CONFIG;
  
@@ -1092,7 +1168,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        /* Get eeprom hw config before calling tg3_set_power_state().
         * In particular, the TG3_FLG2_IS_NIC flag must be
         * determined before calling tg3_set_power_state() so that
-@@ -11184,6 +11246,10 @@ static int __devinit tg3_get_device_addr
+@@ -11184,6 +11256,10 @@ static int __devinit tg3_get_device_addr
        }
  
        if (!is_valid_ether_addr(&dev->dev_addr[0])) {
@@ -1103,7 +1179,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
  #ifdef CONFIG_SPARC64
                if (!tg3_get_default_macaddr_sparc(tp))
                        return 0;
-@@ -11675,6 +11741,7 @@ static char * __devinit tg3_phy_string(s
+@@ -11675,6 +11751,7 @@ static char * __devinit tg3_phy_string(s
        case PHY_ID_BCM5704:    return "5704";
        case PHY_ID_BCM5705:    return "5705";
        case PHY_ID_BCM5750:    return "5750";
@@ -1111,7 +1187,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
        case PHY_ID_BCM5752:    return "5752";
        case PHY_ID_BCM5714:    return "5714";
        case PHY_ID_BCM5780:    return "5780";
-@@ -11859,6 +11926,13 @@ static int __devinit tg3_init_one(struct
+@@ -11859,6 +11936,13 @@ static int __devinit tg3_init_one(struct
                tp->msg_enable = tg3_debug;
        else
                tp->msg_enable = TG3_DEF_MSG_ENABLE;
@@ -1128,7 +1204,7 @@ Index: linux-2.6.23.16/drivers/net/tg3.c
 Index: linux-2.6.23.16/drivers/net/tg3.h
 ===================================================================
 --- linux-2.6.23.16.orig/drivers/net/tg3.h     2008-02-22 19:40:57.000000000 +0100
-+++ linux-2.6.23.16/drivers/net/tg3.h  2008-02-23 19:35:15.000000000 +0100
++++ linux-2.6.23.16/drivers/net/tg3.h  2008-02-23 20:56:08.000000000 +0100
 @@ -2279,6 +2279,10 @@ struct tg3 {
  #define TG3_FLG2_PHY_JITTER_BUG               0x20000000
  #define TG3_FLG2_NO_FWARE_REPORTED    0x40000000
@@ -1158,3 +1234,15 @@ Index: linux-2.6.23.16/drivers/net/tg3.h
  
        struct tg3_hw_stats             *hw_stats;
        dma_addr_t                      stats_mapping;
+Index: linux-2.6.23.16/drivers/ssb/driver_mipscore.c
+===================================================================
+--- linux-2.6.23.16.orig/drivers/ssb/driver_mipscore.c 2008-02-20 20:02:43.000000000 +0100
++++ linux-2.6.23.16/drivers/ssb/driver_mipscore.c      2008-02-28 12:16:12.000000000 +0100
+@@ -211,6 +211,7 @@ void ssb_mipscore_init(struct ssb_mipsco
+                       /* fallthrough */
+               case SSB_DEV_PCI:
+               case SSB_DEV_ETHERNET:
++              case SSB_DEV_ETHERNET_GBIT:
+               case SSB_DEV_80211:
+               case SSB_DEV_USB20_HOST:
+                       /* These devices get their own IRQ line if available, the rest goes on IRQ0 */