major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / target / linux / brcm47xx / Makefile
index 11485fe056e84f9532a73b7a317a31e1c33ce024..5804ee9768c343beb9f4e800a9b25dff95914a47 100644 (file)
@@ -13,15 +13,15 @@ FEATURES:=squashfs usb
 
 LINUX_VERSION:=2.6.22.4
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += kmod-switch kmod-diag
+
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Netgear WGT634U)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
-
 # include the profiles
 -include profiles/*.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))