[backfire] brcm-2.4: filter udevtrigger and hotplug2 from default package list, fixes...
[openwrt-10.03/.git] / target / linux / brcm-2.4 / Makefile
index 4e1267df352eafa32c8f438dbcc980eac52f0720..d1d89419341a321859308c8c5fee95378819a3fa 100644 (file)
@@ -7,77 +7,19 @@
 include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
-BOARD:=brcm
-BOARDNAME:=Broadcom BCM947xx/953xx
+BOARD:=brcm-2.4
+BOARDNAME:=Broadcom BCM947xx/953xx [2.4]
 FEATURES:=squashfs
 
-define Target/Description
-       Build firmware images for Broadcom based routers
-       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
-
-       This one builds the generic .trx images, activate one of the
-       options below for creating device specific files for use
-       with TFTP client too.
-endef
-
 KERNEL:=2.4
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch nvram
+include $(INCLUDE_DIR)/target.mk
 
-define Profile/Broadcom
-  NAME:=Generic, Broadcom WiFi (default)
-  PACKAGES:=kmod-brcm-wl 
-endef
-$(eval $(call Profile,Broadcom))
-
-define Profile/BroadcomMimo
-  NAME:=Generic, Broadcom WiFi (MIMO)
-  PACKAGES:=kmod-brcm-wl-mimo
-endef
-$(eval $(call Profile,BroadcomMimo))
-
-define Profile/Atheros
-  NAME:=Generic, Atheros WiFi
-  PACKAGES:=kmod-madwifi
-endef
-$(eval $(call Profile,Atheros))
-
-define Profile/None
-  NAME:=Generic, No WiFi
-  PACKAGES:=
-endef
-$(eval $(call Profile,None))
+DEFAULT_PACKAGES := $(filter-out udevtrigger hotplug2,$(DEFAULT_PACKAGES)) kmod-switch kmod-diag nvram 
 
-
-define Profile/WRT54G3G
-  NAME:=Linksys WRT54G3G
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt
-endef
-$(eval $(call Profile,WRT54G3G))
-
-define Profile/WL500G
-  NAME:=ASUS WL-500g
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp
-endef
-$(eval $(call Profile,WL500G))
-
-define Profile/WL500GD
-  NAME:=ASUS WL-500g Deluxe
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2
-endef
-$(eval $(call Profile,WL500GD))
-
-define Profile/WL500GP
-  NAME:=ASUS WL-500g Premium
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-$(eval $(call Profile,WL500GP))
-
-define Profile/WLHDD
-  NAME:=WL-HDD
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx
+define Target/Description
+       Build firmware images for Broadcom based routers
+       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
 endef
-$(eval $(call Profile,WLHDD))
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))