make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt-10.03/.git] / target / linux / brcm-2.4 / Makefile
index 20a6210666a7ad91b477e50e29b2a4c2fd87af94..7319ccabd470b62240d6e62c643afdc983da3a35 100644 (file)
@@ -1,26 +1,29 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.4.32
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
-
-include ./config
-include $(TOPDIR)/include/kernel.mk
+ARCH:=mipsel
+BOARD:=brcm
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=pci usb pcmcia squashfs jffs2
 
-# broadcom specific kmod packages
-$(eval $(call KMOD_template,LP,lp,\
-       $(MODULES_DIR)/kernel/drivers/parport/parport.o \
-       $(MODULES_DIR)/kernel/drivers/parport/parport_splink.o \
-       $(MODULES_DIR)/kernel/drivers/char/lp.o \
-       $(MODULES_DIR)/kernel/drivers/char/ppdev.o \
-,CONFIG_PARPORT,,50,parport parport_splink lp))
+define Target/Description
+       Build firmware images for Broadcom based routers
+       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
 
-include $(TOPDIR)/include/kernel-build.mk
+       This one builds the generic .trx images, activate one of the
+       options below for creating device specific files for use
+       with TFTP client too.
+endef
 
+LINUX_VERSION:=2.4.32
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+include $(INCLUDE_DIR)/kernel-build.mk
 
+$(eval $(call BuildKernel))