Add back support for 2.6.21 kernels - add some required directories.
[openwrt-10.03/.git] / target / linux / at91 / Makefile
index f8ca6f6be37d05b6021a28b6050b6d4d4e6011cb..85bb4da49106b047223f77a85e037b0efd86fa96 100644 (file)
@@ -11,17 +11,14 @@ BOARD:=at91
 BOARDNAME:=AT91
 FEATURES:=squashfs usb
 
-#LINUX_VERSION:=2.6.21.5
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.21.5
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
 
 define Target/Description
   Build fimware images for Figment Design Labs VersaLink board.
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
-#include the profiles
--include profiles/*.mk
-
-KERNELNAME:="uImage"
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))