Changed default rootfs size for at91 to 2112k
[openwrt-10.03/.git] / target / linux / at91-2.6 / image / Makefile
index 07660f2350616984c9803b611db31934b627a7bf..e2ace4251b8ad0b491e5f1897a61d7637b3e4862 100644 (file)
@@ -5,16 +5,29 @@
 # See /LICENSE for more information.
 #
 
-TARGET_DEVICE_TABLE:=$(TOPDIR)/target/linux/vlink-2.6/image/device_table.txt
-
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Build/Clean
+       $(MAKE) -C romboot clean
+       $(MAKE) -C u-boot clean
+endef
+
+define Build/Compile
+       $(MAKE) -C romboot compile
+#      $(MAKE) -C u-boot configure
+       $(MAKE) -C u-boot compile
+       $(KDIR)/u-boot-1.1.4/tools/ubparams
+       cp params $(KDIR)
 endef
 
 define Image/Prepare
   cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+       cp $(KDIR)/romboot/romboot.bin $(KDIR)/romboot.bin
+       cp $(KDIR)/romboot/rbptest.bin $(KDIR)/rbptest.bin
+       cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
+       dd if=$(KDIR)/u-boot.bin of=$(KDIR)/u-boot.block bs=100k count=1 conv=sync
+       cat $(KDIR)/u-boot.block $(KDIR)/params > $(KDIR)/u-boot.full
 endef
 
 define Image/BuildKernel
@@ -22,15 +35,12 @@ define Image/BuildKernel
 endef
 
 define Image/Build
+       dd if=$(KDIR)/uImage of=$(KDIR)/uImage.block bs=1056k count=1 conv=sync
+       dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=2112k count=1 conv=sync
+       cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
+       $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/romboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
+       cp $(KDIR)/rbptest.bin $(BIN_DIR)
        $(call Image/Build/$(1),$(1))
 endef
 
-define Image/Build/jffs2-64k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
-endef
-
-define Image/Build/jffs2-128k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
-endef
-
 $(eval $(call BuildImage))