make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt-10.03/.git] / target / linux / aruba-2.6 / Makefile
index 2281033833adee8e5f608e78cdf8c81db163d0e8..c3946e2d10d8dd9979d86b3cc74ed9f1028b70cc 100644 (file)
@@ -1,23 +1,23 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.16.2
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=d4105a5ba1d9f82acee2c525c65ef969
-
-include ../rules.mk
-include ./config
+ARCH:=mips
+BOARD:=aruba
+BOARDNAME:=Aruba
+FEATURES:=jffs2 pci usb
 
-include ../generic-$(KERNEL)/modules.mk
-include ../kernel.mk
+define Target/Description
+       Build firmware images for Aruba boards
+endef
 
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
-ifeq ($(BR2_ARUBA_RAMDISK),y)
-       @$(CP) config-ramdisk $(LINUX_DIR)/.config
-else
-       @$(CP) config $(LINUX_DIR)/.config
-endif
-       touch $@
-
+include $(INCLUDE_DIR)/kernel-build.mk
+$(eval $(call BuildKernel))