ar71xx: sync profile/target default changes with trunk
[openwrt-10.03/.git] / target / linux / ar71xx / profiles / d-link.mk
index 0aa50a640d735012a88739ba399514ad8f545e80..594cfde4fe4213a9900a30d06f4e260da0d091d7 100644 (file)
@@ -5,9 +5,21 @@
 # See /LICENSE for more information.
 #
 
+define Profile/DIR600A1
+       NAME:=D-Link DIR-600 rev. A1
+       PACKAGES:=
+endef
+
+define Profile/DIR600A1/Description
+       Package set optimized for the D-Link DIR-600 rev. A1.
+endef
+
+$(eval $(call Profile,DIR600A1))
+
+
 define Profile/DIR615C1
        NAME:=D-Link DIR-615 rev. C1
-       PACKAGES:=kmod-ath9k
+       PACKAGES:=
 endef
 
 define Profile/DIR615C1/Description
@@ -15,3 +27,15 @@ define Profile/DIR615C1/Description
 endef
 
 $(eval $(call Profile,DIR615C1))
+
+
+define Profile/DIR825B1
+       NAME:=D-Link DIR-825 rev. B1
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/DIR825B1/Description
+       Package set optimized for the D-Link DIR-825 rev. B1.
+endef
+
+$(eval $(call Profile,DIR825B1))