rtl8366_smi: add Kconfig option for the debugfs stuff
[openwrt-10.03/.git] / target / linux / ar71xx / patches-2.6.32 / 204-rtl8366-smi-driver.patch
index 78ec2e44c06fdf63b8da4bd4a8872cb51d355bba..383513cda74bacb85d7016791139eefae8029bd5 100644 (file)
@@ -1,12 +1,18 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -146,4 +146,8 @@ config MDIO_GPIO
+@@ -146,4 +146,14 @@ config MDIO_GPIO
          To compile this driver as a module, choose M here: the module
          will be called mdio-gpio.
  
 +config RTL8366_SMI
 +      tristate "Support for RTL8366 switch via SMI interface"
 +      depends on GENERIC_GPIO
++
++config RTL8366_SMI_DEBUG_FS
++      bool "RTL8366S driver DEBUG_FS support"
++      depends on RTL8366_SMI
++      depends on DEBUG_FS
++      default n
 +
  endif # PHYLIB
 --- a/drivers/net/phy/Makefile