rtl8366: make it available on all platforms
[openwrt-10.03/.git] / target / linux / ar71xx / patches-2.6.30 / 101-ksz8041_phy_driver.patch
index 828a3f9b9aad732d73d95c70f67b2d789a3712f8..2a09911e1ded1ce9661b7077bfaea2007a4cb218 100644 (file)
@@ -1,7 +1,7 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -104,6 +104,11 @@ config AR8216_PHY
-       tristate "Driver for Atheros AR8216 switches"
+@@ -108,6 +108,11 @@ config RTL8306_PHY
+       tristate "Driver for Realtek RTL8306S switches"
        select SWCONFIG
  
 +config MICREL_PHY
@@ -14,9 +14,9 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -19,6 +19,7 @@ obj-$(CONFIG_IP175C_PHY)     += ip175c.o
- obj-$(CONFIG_REALTEK_PHY)     += realtek.o
- obj-$(CONFIG_AR8216_PHY)      += ar8216.o
+@@ -22,6 +22,7 @@ obj-$(CONFIG_RTL8306_PHY)    += rtl8306.o
+ obj-$(CONFIG_RTL8366_SMI)     += rtl8366_smi.o
+ obj-$(CONFIG_RTL8366S_PHY)    += rtl8366s.o
  obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
 +obj-$(CONFIG_MICREL)          += micrel.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o