rtl8366: make it available on all platforms
[openwrt-10.03/.git] / target / linux / ar71xx / patches-2.6.30 / 101-ksz8041_phy_driver.patch
index 0de88532b8374179ca71e3e603599a40e9d9abf5..2a09911e1ded1ce9661b7077bfaea2007a4cb218 100644 (file)
@@ -1,7 +1,7 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -100,6 +100,11 @@ config AR8216_PHY
-       tristate "Driver for Atheros AR8216 switches"
+@@ -108,6 +108,11 @@ config RTL8306_PHY
+       tristate "Driver for Realtek RTL8306S switches"
        select SWCONFIG
  
 +config MICREL_PHY
@@ -14,9 +14,9 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
- obj-$(CONFIG_REALTEK_PHY)     += realtek.o
- obj-$(CONFIG_AR8216_PHY)      += ar8216.o
+@@ -22,6 +22,7 @@ obj-$(CONFIG_RTL8306_PHY)    += rtl8306.o
+ obj-$(CONFIG_RTL8366_SMI)     += rtl8366_smi.o
+ obj-$(CONFIG_RTL8366S_PHY)    += rtl8366s.o
  obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
 +obj-$(CONFIG_MICREL)          += micrel.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o