make target/linux/* directories self-contained, use the selected kernel version for...
[openwrt-10.03/.git] / target / linux / ar531x-2.4 / Makefile
index b33898754b67c003499cd9f10098fdeaf9f7a8cd..7201c04d29ec2a466b3ccf43e0ab4c6575bd37db 100644 (file)
@@ -1,16 +1,25 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
+ARCH:=mips
+BOARD:=ar531x
+BOARDNAME:=Atheros AR531x
+FEATURES:=broken jffs2
+
+define Target/Description
+       Build firmware images for Atheros AR531x based boards
+       (e.g. Netgear WGT624, Linksys WRT55AG)
+endef
+
+
 LINUX_VERSION:=2.4.32
 LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
 
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/kernel-build.mk
-
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
-
+$(eval $(call BuildKernel))