[amazon] move files to correct position
[openwrt-10.03/.git] / target / linux / amazon / Makefile
index 826937a5fed2bae912c3e6009e21fbfc94068726..aae39a00e91b8c3a4905888992a7e605a66c3550 100644 (file)
@@ -18,12 +18,4 @@ define Target/Description
        Build firmware images for Infineon Amazon boards
 endef
 
-ifeq ($(KERNEL_PATCHVER),2.6.30)
-  define Kernel/Prepare
-       $(call Kernel/Prepare/Default)
-       mv $(LINUX_DIR)/include/asm-mips/mach-amazon $(LINUX_DIR)/arch/mips/include/asm/mach-amazon
-       mv $(LINUX_DIR)/drivers/char/watchdog/amazon_wdt.c $(LINUX_DIR)/drivers/watchdog/amazon_wdt.c
-  endef
-endif
-
 $(eval $(call BuildTarget))