major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / target / linux / amazon / Makefile
index 1967d52f42a2febe58017707279cb820b754cccd..17f9d964941a61b971b776e82a556763a9f0763c 100644 (file)
@@ -10,6 +10,9 @@ ARCH:=mips
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs jffs2 broken
+LINUX_VERSION:=2.6.21.5
+
+include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
        Build firmware images for Infineon Amazon boards
@@ -17,9 +20,7 @@ endef
 
 KERNELNAME:="uImage"
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
 # include the profiles
 -include profiles/*.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))