build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / target / linux / amazon-2.6 / image / Makefile
index c749560db9ea47a1924a5c361ced4b8983e0ff06..29935f924123316a45e7d4fca639181db9ec7d8e 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/BuildKernel
-       $(STAGING_DIR)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+       $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
        mkimage -A mips -O linux -T kernel -C lzma -a 0x80002000 -e \
                0x80002000 \
                -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \