build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / target / linux / adm5120eb-2.6 / image / Makefile
index 82ecedc1d03330683a6e590f940dcd1536e23c26..f47b3ab0b80492fd5ecc93acbcdca6931ea47757 100644 (file)
@@ -7,21 +7,22 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Compile
-       rm -f $(KDIR)/loader-zynos.gz $(KDIR)/loader-zynos.bin
-       $(MAKE) -C lzma-loader \
-               BUILD_DIR="$(KDIR)" \
-               TARGET="$(KDIR)" \
-               LOADER=loader-zynos \
-               install
+IMGNAME = $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)
+LOADER_MAKE = $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
+
+define Image/Build/Loader
+       $(LOADER_MAKE) LOADER=loader-$(1).$(2) LOADER_DATA="" \
+               LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
+               CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
+               compile loader.$(2)
 endef
 
 define Build/Clean
-       $(MAKE) -C lzma-loader clean
+       $(LOADER_MAKE) clean
 endef
 
 define Image/Prepare
-       cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+       cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
 endef
 
 define trxalign/jffs2-128k
@@ -34,15 +35,46 @@ define trxalign/squashfs
 -a 1024
 endef
 
+define Image/Build/TRX
+       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(3) -f $(KDIR)/vmlinux.lzma \
+               $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
+endef
+
+define Image/Build/TRXNoloader
+       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(KDIR)/vmlinux.lzma \
+               $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
+endef
+
 define Image/Build/ZyXEL
-       $(CP) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-noloader.trx $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).trx
+       $(call Image/Build/Loader,loader-$(2),gz,0x80500000,0)
+       $(call Image/Build/TRXNoloader,$(IMGNAME)-$(3)-$(2).trx,$(1))
+       #TODO: firmware generation tool needed
 endef
 
 define Image/Build
-       $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-noloader.trx -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
-ifneq ($(1),jffs2-128K)
-       #FIXME: no supported boards yet
+       #FIXME: No firmware images yet
+endef
+
+define Image/Build/LZMAKernel
+       $(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \
+               LOADER=openwrt-$(BOARD)-$(KERNEL)-ramfs-lzma-$(1).$(2) \
+               LOADER_DATA=$(KDIR)/vmlinux.lzma \
+               LZMA_TEXT_START=$(3) LZMA_STARTUP_ORG=$(4) \
+               CONFIG_PASS_KARGS=$(5) CONFIG_BOARD=$(6) \
+               compile loader.$(2)
+endef
+
+define Image/Build/LZMAKernel/ZyXEL
+       $(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0,y,$(1))
+endef
+
+define Image/Build/Initramfs
+# this line is here intentionally
+ifeq ($(CONFIG_DEVEL),y)
+       $(call Image/Build/LZMAKernel/ZyXEL,p-334wt,bin)
+       $(call Image/Build/LZMAKernel/ZyXEL,p-335,bin)
 endif
 endef
 
 $(eval $(call BuildImage))
+