build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail...
[openwrt-10.03/.git] / target / linux / adm5120eb-2.6 / image / Makefile
index 5772272090c2df0121df4d380920fbcf8ad500f9..f47b3ab0b80492fd5ecc93acbcdca6931ea47757 100644 (file)
@@ -22,7 +22,7 @@ define Build/Clean
 endef
 
 define Image/Prepare
-       cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+       cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
 endef
 
 define trxalign/jffs2-128k
@@ -36,12 +36,12 @@ define trxalign/squashfs
 endef
 
 define Image/Build/TRX
-       $(STAGING_DIR)/bin/trx -o $(1) -f $(3) -f $(KDIR)/vmlinux.lzma \
+       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(3) -f $(KDIR)/vmlinux.lzma \
                $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
 endef
 
 define Image/Build/TRXNoloader
-       $(STAGING_DIR)/bin/trx -o $(1) -f $(KDIR)/vmlinux.lzma \
+       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(KDIR)/vmlinux.lzma \
                $(call trxalign/$(2)) -f $(KDIR)/root.$(2)
 endef
 
@@ -70,7 +70,7 @@ endef
 
 define Image/Build/Initramfs
 # this line is here intentionally
-ifeq (CONFIG_DEVEL,y)
+ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/LZMAKernel/ZyXEL,p-334wt,bin)
        $(call Image/Build/LZMAKernel/ZyXEL,p-335,bin)
 endif