Add hostapd-mini to default images where applicable
[openwrt-10.03/.git] / target / linux / adm5120 / router_le / profiles / Cellvision.mk
index 9c8356a663408c95d237070f59a3cc1355af8829..9fa1e02330e12cc9d1a8ba0fadfd0050f7bf9bf2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007,2008 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,6 +8,7 @@
 define Profile/CAS630
        NAME:=Cellvision CAS-630 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS630/Description
@@ -17,6 +18,7 @@ endef
 define Profile/CAS630W
        NAME:=Cellvision CAS-630W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS630W/Description
@@ -26,6 +28,7 @@ endef
 define Profile/CAS670
        NAME:=Cellvision CAS-670 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS670/Description
@@ -35,6 +38,7 @@ endef
 define Profile/CAS670W
        NAME:=Cellvision CAS-670W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS670W/Description
@@ -44,6 +48,7 @@ endef
 define Profile/CAS700
        NAME:=Cellvision CAS-700 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS700/Description
@@ -53,6 +58,7 @@ endef
 define Profile/CAS700W
        NAME:=Cellvision CAS-700W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS700W/Description
@@ -61,7 +67,7 @@ endef
 
 define Profile/CAS771
        NAME:=Cellvision CAS-771 IP camera (Experimental)
-       PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
+       PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
 define Profile/CAS771/Description
@@ -70,7 +76,7 @@ endef
 
 define Profile/CAS771W
        NAME:=Cellvision CAS-771W IP camera (Experimental)
-       PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
+       PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
 endef
 
 define Profile/CAS771W/Description
@@ -80,6 +86,7 @@ endef
 define Profile/CAS790
        NAME:=Cellvision CAS-790 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS790/Description
@@ -89,6 +96,7 @@ endef
 define Profile/CAS861
        NAME:=Cellvision CAS-861 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS861/Description
@@ -106,6 +114,7 @@ endef
 
 define Profile/NFS101U
        NAME:=Cellvision NFS-101U Network File Server (Experimental)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/NFS101U/Description
@@ -114,6 +123,7 @@ endef
 
 define Profile/NFS101WU
        NAME:=Cellvision NFS-101WU Network File Server (Experimental)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/NFS101WU/Description