[adm5120] generate firmware images for the CAS-700/771/790/861 devices
[openwrt-10.03/.git] / target / linux / adm5120 / router_le / profiles / Cellvision.mk
index 44656ffe996443f5ea3249fe5a32b72bc2c89e39..218c2b5079854fd098b604c17f7349b011838da2 100644 (file)
@@ -1,12 +1,30 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
+define Profile/CAS700
+       NAME:=Cellvision CAS-700 IP camera (Untested)
+       # TODO: add default packages
+endef
+
+define Profile/CAS700/Description
+       Package set optimized for the Cellvision CAS-700 device.
+endef
+
+define Profile/CAS700W
+       NAME:=Cellvision CAS-700W IP camera (Untested)
+       # TODO: add default packages
+endef
+
+define Profile/CAS700W/Description
+       Package set optimized for the Cellvision CAS-700W device.
+endef
+
 define Profile/CAS771
-       NAME:=Cellvision CAS-771 IP camera
+       NAME:=Cellvision CAS-771 IP camera (Untested)
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
@@ -15,7 +33,7 @@ define Profile/CAS771/Description
 endef
 
 define Profile/CAS771W
-       NAME:=Cellvision CAS-771W IP camera
+       NAME:=Cellvision CAS-771W IP camera (Untested)
        PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500
 endef
 
@@ -23,5 +41,37 @@ define Profile/CAS771W/Description
        Package set optimized for the Cellvision CAS-771W device.
 endef
 
+define Profile/CAS790
+       NAME:=Cellvision CAS-790 IP camera (Untested)
+       # TODO: add default packages
+endef
+
+define Profile/CAS790/Description
+       Package set optimized for the Cellvision CAS-790 device.
+endef
+
+define Profile/CAS861
+       NAME:=Cellvision CAS-861 IP camera (Untested)
+       # TODO: add default packages
+endef
+
+define Profile/CAS861/Description
+       Package set optimized for the Cellvision CAS-861 device.
+endef
+
+define Profile/CAS861W
+       NAME:=Cellvision CAS-861W IP camera (Untested)
+       PACKAGES:=kmod-rt2500
+endef
+
+define Profile/CAS861W/Description
+       Package set optimized for the Cellvision CAS-861W device.
+endef
+
+$(eval $(call Profile,CAS700))
+$(eval $(call Profile,CAS700W))
 $(eval $(call Profile,CAS771))
 $(eval $(call Profile,CAS771W))
+$(eval $(call Profile,CAS790))
+$(eval $(call Profile,CAS861))
+$(eval $(call Profile,CAS861W))