[adm5120] make build of the images a bit quiet
[openwrt-10.03/.git] / target / linux / adm5120 / image / router_le.mk
index 9f1aa9b2bee1a94c341dc20a6f39027323ec304e..4cb070ead4e95a42bf6f3a2def25eb752de34388 100644 (file)
@@ -5,6 +5,23 @@
 # See /LICENSE for more information.
 #
 
+define trxedimax/jffs2-128k
+-a 0x20000 -f $(KDIR)/root.jffs2-128k
+endef
+
+define trxedimax/jffs2-64k
+-a 0x10000 -f $(KDIR)/root.jffs2-64k
+endef
+
+define trxedimax/squashfs
+-a 1024 -f $(KDIR)/root.squashfs
+endef
+
+define Image/Build/TRXEdimax
+       $(STAGING_DIR_HOST)/bin/trx -o $(1) -f $(KDIR)/vmlinux.lzma \
+               $(call trxedimax/$(2))
+endef
+
 define Image/Build/Compex
        $(call Image/Build/Loader,$(2),gz,0x80500000,0,y,$(2))
        $(call Image/Build/TRX,$(call imgname,$(1),$(2)).trx,$(1),$(KDIR)/loader-$(2).gz)
@@ -12,11 +29,18 @@ endef
 
 define Image/Build/Edimax
        $(call Image/Build/Loader,$(2),gz,0x80500000,0x6D8,y,$(2))
-       $(call Image/Build/TRXNoloader,$(call imgname,$(1),$(2)).trx,$(1))
+       $(call Image/Build/TRXEdimax,$(call imgname,$(1),$(2)).trx,$(1))
        $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d -w \
-               -r $(KDIR)/loader-$(2).gz \
-               -x $(call imgname,$(1),$(2)).trx \
-               $(call imgname,$(1),$(2)).bin
+               -r $(KDIR)/loader-$(2).gz::0x1000 \
+               -x $(call imgname,$(1),$(2)).trx:0x10000 \
+               -x $(JFFS2MARK):0x10000 \
+               $(call imgname,$(1),$(2))-webui.bin
+       $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d \
+               -r $(KDIR)/loader-$(2).gz::0x1000 \
+               -x $(call imgname,$(1),$(2)).trx:0x10000 \
+               -x $(JFFS2MARK):0x10000 \
+               $(call imgname,$(1),$(2))-xmodem.bin
+       rm -f $(call imgname,$(1),$(2)).trx
 endef
 
 define Image/Build/Infineon
@@ -185,7 +209,7 @@ define Image/Build/Board/WP54GWRT/Initramfs
 endef
 
 #
-# Edimax BR-6104K/KP
+# Edimax BR-6104K
 #
 define Image/Build/Board/BR6104K
        $(call Image/Build/Edimax,$(1),br-6104k)
@@ -195,14 +219,40 @@ define Image/Build/Board/BR6104K/squashfs
        $(call Image/Build/Board/BR6104K,squashfs)
 endef
 
-define Image/Build/Board/BR6104K/jffs2-64k
-       $(call Image/Build/Board/BR6104K,jffs2-64k)
-endef
-
 define Image/Build/Board/BR6104K/Initramfs
        $(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
 endef
 
+#
+# Edimax BR-6104KP
+#
+define Image/Build/Board/BR6104KP
+       $(call Image/Build/Edimax,$(1),br-6104kp)
+endef
+
+define Image/Build/Board/BR6104KP/squashfs
+       $(call Image/Build/Board/BR6104KP,squashfs)
+endef
+
+define Image/Build/Board/BR6104KP/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,br-6104kp,gz)
+endef
+
+#
+# Edimax BR-6104WG
+#
+define Image/Build/Board/BR6104WG
+       $(call Image/Build/Edimax,$(1),br-6104wg)
+endef
+
+define Image/Build/Board/BR6104WG/squashfs
+       $(call Image/Build/Board/BR6104WG,squashfs)
+endef
+
+define Image/Build/Board/BR6104WG/Initramfs
+       $(call Image/Build/LZMAKernel/Admboot,br-6104wg,gz)
+endef
+
 #
 # Infineon EASY 83000
 #
@@ -248,12 +298,13 @@ endef
 define Image/Build/Group/Compex
        $(call Image/Build/Board/NP27G/$(1))
        $(call Image/Build/Board/NP28G/$(1))
-
        $(call Image/Build/Group/WP54G,$(1))
 endef
 
 define Image/Build/Group/Edimax
        $(call Image/Build/Board/BR6104K/$(1))
+       $(call Image/Build/Board/BR6104KP/$(1))
+       $(call Image/Build/Board/BR6104WG/$(1))
 endef
 
 define Image/Build/Group/Infineon
@@ -308,6 +359,14 @@ define Image/Build/Profile/CAS771W
        $(call Image/Build/Board/CAS771W/$(1))
 endef
 
+define Image/Build/Profile/BR6104K
+       $(call Image/Build/Board/BR6104K/$(1))
+endef
+
+define Image/Build/Profile/BR6104KP
+       $(call Image/Build/Board/BR6104KP/$(1))
+endef
+
 define Image/Build/Profile/RouterBoard
        $(call Image/Build/Board/RB1xx/$(1))
 endef