update targets to 2.6.25.10
[openwrt-10.03/.git] / target / linux / adm5120 / Makefile
index e53bd5d2142d7f968b930fc1b42683b0c342dd3e..f96a5cebe8bcdb31f65af521363076c0e3e79563 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007,2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
-BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.23.9
-FEATURES:=squashfs jffs2 tgz broken
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=2.6.25.10
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += admswconfig
+DEFAULT_PACKAGES += \
+       kmod-input-core \
+       kmod-input-polldev \
+       kmod-input-gpio-buttons \
+       kmod-button-hotplug
 
 $(eval $(call BuildTarget))