next round of cleanup, convert target/ - make -j works now ;)
[openwrt-10.03/.git] / target / linux / Makefile
index c15d81999f74aa1b451e0d05d998f6dc50d87cb9..608cfa8eb06e8be63b44f9bb245f93e3036da14c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,20 +7,6 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-download:
-       $(MAKE) -C $(BOARD)-$(KERNEL) download
+prereq clean download prepare compile install menuconfig oldconfig update refresh: FORCE
+       $(MAKE) -C $(BOARD)-$(KERNEL) $@
 
-prepare:
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-menuconfig:
-       $(MAKE) -C $(BOARD)-$(KERNEL) menuconfig
-
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean