next round of cleanup, convert target/ - make -j works now ;)
[openwrt-10.03/.git] / target / linux / Makefile
index bab26845a15aae8e7b059af587f15ca386d1cf59..608cfa8eb06e8be63b44f9bb245f93e3036da14c 100644 (file)
@@ -1,18 +1,12 @@
+# 
+# Copyright (C) 2006-2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-source:
-       $(MAKE) -C $(BOARD)-$(KERNEL) source
+prereq clean download prepare compile install menuconfig oldconfig update refresh: FORCE
+       $(MAKE) -C $(BOARD)-$(KERNEL) $@
 
-prepare:
-       rm -f $(TOPDIR)/.kernel.mk
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean