add kernel_oldconfig target
[openwrt-10.03/.git] / target / linux / Makefile
index bab26845a15aae8e7b059af587f15ca386d1cf59..5a1ca723a6305338304e4b7227eb41297b09c237 100644 (file)
@@ -1,18 +1,12 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-source:
-       $(MAKE) -C $(BOARD)-$(KERNEL) source
+clean download prepare compile install menuconfig oldconfig update refresh: FORCE
+       $(MAKE) -C $(BOARD)-$(KERNEL) $@
 
-prepare:
-       rm -f $(TOPDIR)/.kernel.mk
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean