add kernel_oldconfig target
[openwrt-10.03/.git] / target / linux / Makefile
index 604c739b599191a78d5ae4516180ad643f2be627..5a1ca723a6305338304e4b7227eb41297b09c237 100644 (file)
@@ -1,42 +1,12 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
 
-define kernel_template
+clean download prepare compile install menuconfig oldconfig update refresh: FORCE
+       $(MAKE) -C $(BOARD)-$(KERNEL) $@
 
-$(1)/$(2)-clean:
-       $(MAKE) -C linux-$(1) BOARD="$(2)" clean
-
-$(1)/$(2)-prepare:
-       $(MAKE) -C linux-$(1) BOARD="$(2)" prepare
-
-$(1)/$(2)-compile:
-       $(MAKE) -C linux-$(1) BOARD="$(2)" compile
-
-$(1)/$(2)-rebuild:
-       $(MAKE) -C linux-$(1) BOARD="$(2)" rebuild
-
-$(1)/$(2)-install:
-       $(MAKE) -C linux-$(1) BOARD="$(2)" install
-
-$(1)/$(2)-image: $(1)/$(2)-install
-       $(MAKE) -C image KERNEL="$(1)" BOARD="$(2)" install
-
-ifeq ($(BR2_LINUX_$(3)),y)
-clean: $(1)/$(2)-clean
-prepare: $(1)/$(2)-prepare
-compile: $(1)/$(2)-compile
-rebuild: $(1)/$(2)-rebuild
-install: $(1)/$(2)-image
-endif
-
-.PHONY: $(1)/$(2)-clean $(1)/$(2)-prepare $(1)/$(2)-compile $(1)/$(2)-rebuild $(1)/$(2)-install
-endef
-
-prepare:
-       $(MAKE) -C image prepare
-compile:
-       $(MAKE) -C image compile
-install:
-rebuild:
-clean:
-
-$(eval $(call kernel_template,2.4,brcm,2_4_BRCM))