backfire: ImageBuilder: respect the PROFILE parameter (backport of r29877)
[openwrt-10.03/.git] / target / imagebuilder / files / Makefile
index 75129ffd2a166719517f2f532d3a4be3d7130836..f74b40789619d62ea31ac10a56a4362c3bfee3c2 100644 (file)
@@ -38,7 +38,7 @@ Building images:
        By default 'make image' will create an image with the default
        target profile and package set. You can use the following parameters
        to change that:
-       
+
        make image PROFILE="<profilename>" # override the default target profile
        make image PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
        make image FILES="<path>" # include extra files from <path>
@@ -100,14 +100,20 @@ _call_image:
        echo
        rm -rf $(TARGET_DIR)
        mkdir -p $(TARGET_DIR) $(BIN_DIR) $(TMP_DIR)
-       $(MAKE) package_index
+       if [ ! -f "$(PACKAGE_DIR)/Packages" ] || [ ! -f "$(PACKAGE_DIR)/Packages.gz" ] || [ "`find $(PACKAGE_DIR) -cnewer $(PACKAGE_DIR)/Packages.gz`" ]; then \
+               echo "Package list missing or not up-to-date, generating it.";\
+               $(MAKE) package_index; \
+       else \
+               mkdir -p $(TARGET_DIR)/tmp; \
+               $(OPKG) update; \
+       fi
        $(MAKE) package_install
 ifneq ($(USER_FILES),)
        $(MAKE) copy_files
 endif
        $(MAKE) package_postinst
        $(MAKE) build_image
-       
+
 package_index: FORCE
        @echo
        @echo Building package index...
@@ -121,6 +127,7 @@ package_install: FORCE
        @echo
        @echo Installing packages...
        $(OPKG) install $(BUILD_PACKAGES)
+       rm -f $(TARGET_DIR)/usr/lib/opkg/lists/*
 
 copy_files: FORCE
        @echo
@@ -145,8 +152,9 @@ package_postinst: FORCE
 build_image: FORCE
        @echo
        @echo Building images...
-       $(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1
-       
+       $(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1 \
+               $(if $(USER_PROFILE),PROFILE="$(USER_PROFILE)")
+
 clean:
        rm -rf $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR) $(BIN_DIR)