Use find -exec instead of xargs
[openwrt-10.03/.git] / target / imagebuilder / Makefile
index 0cbbfa28353101c18e5e558741fd0147b0c899ee..3d830bbc2d79a2f05ac99653678ac9a4d1aba4c7 100644 (file)
@@ -33,8 +33,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
        $(CP) $(TOPDIR)/target/linux/* $(IB_BUILD_DIR)/target/linux
        rm -rf $(IB_BUILD_DIR)/target/linux/*/patches
        -cp $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/* $(IB_BUILD_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD) # don't copy subdirectories here
-       find $(IB_BUILD_DIR) -name .svn | xargs rm -rf 
-       find $(IB_BUILD_DIR) -name CVS | xargs rm -rf 
+       find $(IB_BUILD_DIR) -name .svn -exec rm -rf {} \;
+       find $(IB_BUILD_DIR) -name CVS -exec rm -rf  {} \;
        (cd $(BUILD_DIR); \
                tar cfj $@ $(IB_NAME); \
        )