code to bring in the following for x86:
[openwrt-10.03/.git] / target / image / x86 / Makefile
index 086024545396d6a917d31baae7f454690b828606..8c0cde440fbdbd04733d678846865307c9f89b7f 100644 (file)
@@ -25,7 +25,7 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
   endef
 
   define Image/cmdline/ext2
-    root=/dev/hda2 rootfstype=ext2
+    root=$(CONFIG_X86_GRUB_ROOTPART) rootfstype=ext2 $(CONFIG_X86_GRUB_BOOTOPTS)
   endef
 
   define Image/Build/grub