leave out the ccache directory when copying the staging dir into the sdk (#843)
[openwrt-10.03/.git] / target / Makefile
index b039214860e20d94742517eb5d0b3264ae9b5cec..dc21033e5f6bd04caed4d04657f7e77c364614b8 100644 (file)
@@ -1,35 +1,48 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
 
 all: install
 
 $(BIN_DIR):
        mkdir -p $(BIN_DIR)
 
-linux-compile: utils-install lzma-install
+TARGETS-y := linux utils
+TARGETS-$(CONFIG_SDK) += sdk
+
+linux-compile: utils-install
 linux-install: $(BIN_DIR)
+image_install: linux-install
 
+download: $(patsubst %,%-download,$(TARGETS-y))
 prepare: linux-prepare
-compile: linux-compile
-install: image_clean linux-install
-clean: linux-clean utils-clean lzma-clean image_clean
+compile: linux-compile image_compile
+install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
+clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
 
-image_clean:
+image_clean: FORCE
+       $(MAKE) -C image/$(BOARD) clean
        rm -f $(BIN_DIR)/openwrt-*
+       
+image_compile: FORCE
+       $(MAKE) -C image/$(BOARD) compile
 
-linux/package/%:
-       $(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
+image_install: image_compile
+       $(MAKE) -C image/$(BOARD) install
 
-%-clean:
+%-clean: FORCE
        $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-prepare:
+%-download: FORCE
+       $(MAKE) -C $(patsubst %-download,%,$@) download
+%-prepare: FORCE
        $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
 %-compile: %-prepare
        $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-rebuild: 
-       $(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
 %-install: %-compile
        $(MAKE) -C $(patsubst %-install,%,$@) install
-linux-imagebuilder:
-       $(MAKE) -C linux imagebuilder
-