update madwifi SoC support patch, add device ids for 2317 (will be functional after...
[openwrt-10.03/.git] / target / Makefile
index 0a1434472a8f49a53e986353d697146d8f83f797..651c13f6ff91dff08b5e3f7a9e11541a36c78452 100644 (file)
@@ -1,30 +1,50 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
 
 all: install
 
 $(BIN_DIR):
        mkdir -p $(BIN_DIR)
 
-TARGETS-y := linux utils
+TARGETS-y := linux
 TARGETS-$(CONFIG_SDK) += sdk
 
-linux-compile: utils-install
 linux-install: $(BIN_DIR)
-sdk-compile: linux-install
+image_install: linux-install
 
-download: $(patsubst %,%-source,$(TARGETS-y))
+IMAGE_DIR:=linux/$(BOARD)-$(KERNEL)/image
+
+
+download: $(patsubst %,%-download,$(TARGETS-y))
 prepare: linux-prepare
-compile: linux-compile
-install: image_clean $(patsubst %,%-install,$(TARGETS-y))
+compile: linux-compile image_compile
+install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
 clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
 
+prereq: FORCE
+       $(MAKE) -C linux/$(BOARD)-$(KERNEL) prereq
+       $(MAKE) -C $(IMAGE_DIR) prereq
+
 image_clean: FORCE
+       $(MAKE) -C $(IMAGE_DIR) clean
        rm -f $(BIN_DIR)/openwrt-*
+       
+image_compile: FORCE
+       $(MAKE) -C $(IMAGE_DIR) compile
+
+image_install: image_compile
+       $(MAKE) -C $(IMAGE_DIR) install
 
 %-clean: FORCE
        $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-source: FORCE
-       $(MAKE) -C $(patsubst %-source,%,$@) source
+%-download: FORCE
+       $(MAKE) -C $(patsubst %-download,%,$@) download
 %-prepare: FORCE
        $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
 %-compile: %-prepare