move tools from toolchain/ to tools/
[openwrt-10.03/.git] / target / Makefile
index 0a1434472a8f49a53e986353d697146d8f83f797..195878e6654d0e4c8fd35f50ceb14b07873c9891 100644 (file)
@@ -1,4 +1,11 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
 
 all: install
 
@@ -11,20 +18,28 @@ TARGETS-$(CONFIG_SDK) += sdk
 linux-compile: utils-install
 linux-install: $(BIN_DIR)
 sdk-compile: linux-install
+image_install: linux-install
 
-download: $(patsubst %,%-source,$(TARGETS-y))
+download: $(patsubst %,%-download,$(TARGETS-y))
 prepare: linux-prepare
-compile: linux-compile
-install: image_clean $(patsubst %,%-install,$(TARGETS-y))
+compile: linux-compile image_compile
+install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
 clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
 
 image_clean: FORCE
+       $(MAKE) -C image/$(BOARD) clean
        rm -f $(BIN_DIR)/openwrt-*
+       
+image_compile: FORCE
+       $(MAKE) -C image/$(BOARD) compile
+
+image_install: image_compile
+       $(MAKE) -C image/$(BOARD) install
 
 %-clean: FORCE
        $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-source: FORCE
-       $(MAKE) -C $(patsubst %-source,%,$@) source
+%-download: FORCE
+       $(MAKE) -C $(patsubst %-download,%,$@) download
 %-prepare: FORCE
        $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
 %-compile: %-prepare