motorola docs from nate
[openwrt-10.03/.git] / target / Makefile.in
index 802b576fbacb90e9e9b77ca296e2f2f92031d8f1..d40fd158d786a6072a6f572c53f6a9e31537d46b 100644 (file)
@@ -1,17 +1,20 @@
 # Default target skeleton stuff, may be overridden
+EXTRAVERSION:=
 TARGET_SKELETON=target/default/skel.tar.gz
 TARGET_SKEL_DIR=target/default/target_skeleton
 
 include target/device/Makefile.in
 
 openwrt-linux.trx: openwrt-trx
-       PATH=$(TARGET_PATH) trx -o openwrt-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+       PATH=$(TARGET_PATH) trx -o openwrt-linux$(EXTRAVERSION).trx \
+        $(LINUX_DIR)/$(LINUX_BINLOC) $(JFFS2FLAGS) $(IMAGE).$(ROOTFS)
 
-openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
-       PATH=$(TARGET_PATH) addpattern -2 -i  openwrt-linux.trx -o openwrt-gs-code.bin -g
+openwrt-code.bin: openwrt-addpattern openwrt-linux.trx
+       PATH=$(TARGET_PATH) addpattern -2 -i  openwrt-linux$(EXTRAVERSION).trx \
+       -o openwrt-$(TAG)-code$(EXTRAVERSION).bin -g
+       @$(SED) "1s,^W54S,$(TAG)," openwrt-$(TAG)-code$(EXTRAVERSION).bin
 
-openwrt-g-code.bin: openwrt-gs-code.bin
-       sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin > openwrt-g-code.bin
-
-openwrt-image: openwrt-g-code.bin
+openwrt-image-clean: 
+       @-rm openwrt-* 2>/dev/null
 
+openwrt-image-dirclean: openwrt-dirclean