sync with buildroot2 from uclibc, add devices, may be used to build other kernel...
[openwrt-10.03/.git] / target / Makefile.in
index c01ade299a908e776344ace49abd9c5af1f8ced8..802b576fbacb90e9e9b77ca296e2f2f92031d8f1 100644 (file)
@@ -1 +1,17 @@
-# Nothing
+# Default target skeleton stuff, may be overridden
+TARGET_SKELETON=target/default/skel.tar.gz
+TARGET_SKEL_DIR=target/default/target_skeleton
+
+include target/device/Makefile.in
+
+openwrt-linux.trx: openwrt-trx
+       PATH=$(TARGET_PATH) trx -o openwrt-linux.trx $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFS)
+
+openwrt-gs-code.bin: openwrt-addpattern openwrt-linux.trx
+       PATH=$(TARGET_PATH) addpattern -2 -i  openwrt-linux.trx -o openwrt-gs-code.bin -g
+
+openwrt-g-code.bin: openwrt-gs-code.bin
+       sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin > openwrt-g-code.bin
+
+openwrt-image: openwrt-g-code.bin
+