[scripts] do not check for a specific Cygwin version, rather check the operating...
[openwrt-10.03/.git] / scripts / config / lxdialog / Makefile
index 3758637ccf997e2477528e22108ed14336a6c1d8..74ee942cd680efef564e8b21430af2355f312857 100644 (file)
@@ -12,8 +12,7 @@ LIBS := $(shell sh check-lxdialog.sh -ldflags gcc)
 OS := $(shell uname -s)
 ifeq ($(strip $(OS)),OpenBSD)
 LIBS := -lncurses
-endif
-ifeq ($(strip $(OS)),CYGWIN_NT-5.1)
+ifeq ($(shell uname -o),Cygwin)
 LIBS := -lncurses
 endif
 always         := $(hostprogs-y) dochecklxdialog