disable gettext in menuconfig
[openwrt-10.03/.git] / scripts / config / Makefile
index 04e8330a01d5db18fd7ef8e790dbc3c725ad4405..5ef8b5488bf7c0006e04a2503684f8a1d7373187 100644 (file)
@@ -1,5 +1,5 @@
 # ===========================================================================
-# Kernel configuration targets
+# OpenWrt configuration targets
 # These targets are used from top-level makefile
 
 # ===========================================================================
@@ -9,6 +9,12 @@
 #         Utilizes the lxdialog package
 # object files used by all kconfig flavours
 
+
+# Platform specific fixes
+#
+# FreeBSD
+export CFLAGS+=-DKBUILD_NO_NLS
+
 conf-objs      := conf.o zconf.tab.o
 mconf-objs     := mconf.o zconf.tab.o
 
@@ -40,10 +46,10 @@ lex.zconf.c: zconf.l
 zconf.hash.c: zconf.gperf
 
 %.tab.c: %.y
-       bison -l -b $* -p $(notdir $*) $< && cp $@ $@_shipped || cp $@_shipped $@
+       cp $@_shipped $@ || bison -l -b $* -p $(notdir $*) $<
 
 lex.%.c: %.l
-       flex -L -P$(notdir $*) -o$@ $< && cp $@ $@_shipped || cp $@_shipped $@
+       cp $@_shipped $@ || flex -L -P$(notdir $*) -o$@ $<
 
 %.hash.c: %.gperf
-       gperf < $< > $@ && cp $@ $@_shipped || cp $@_shipped $@
+       cp $@_shipped $@ || gperf < $< > $@