add possibility to set default .config values
[openwrt-10.03/.git] / scripts / config / Makefile
index 04e8330a01d5db18fd7ef8e790dbc3c725ad4405..54c5fe25afe811e7df1cae401e7235f930b49e28 100644 (file)
@@ -1,5 +1,5 @@
 # ===========================================================================
-# Kernel configuration targets
+# OpenWrt configuration targets
 # These targets are used from top-level makefile
 
 # ===========================================================================
@@ -9,26 +9,31 @@
 #         Utilizes the lxdialog package
 # object files used by all kconfig flavours
 
+
+# Platform specific fixes
+#
+# FreeBSD
+export CFLAGS+=-DKBUILD_NO_NLS
+
 conf-objs      := conf.o zconf.tab.o
 mconf-objs     := mconf.o zconf.tab.o
 
 clean-files    := lkc_defs.h qconf.moc .tmp_qtcheck \
                   .tmp_gtkcheck zconf.tab.c lex.zconf.c zconf.hash.c
 
-all: conf mconf lxdialog
+all: conf mconf lxdialog/lxdialog
 
-.PHONY: lxdialog
-lxdialog:
+lxdialog/lxdialog:
        $(MAKE) -C lxdialog
 
 conf: $(conf-objs)
-mconf: $(mconf-objs)
+mconf: $(mconf-objs) 
 
 clean:
        rm -f *.o $(clean-files) conf mconf
        $(MAKE) -C lxdialog clean
 
-zconf.tab.o: lex.zconf.c zconf.hash.c
+zconf.tab.o: lex.zconf.c zconf.hash.c confdata.c
 
 kconfig_load.o: lkc_defs.h
 
@@ -40,10 +45,10 @@ lex.zconf.c: zconf.l
 zconf.hash.c: zconf.gperf
 
 %.tab.c: %.y
-       bison -l -b $* -p $(notdir $*) $< && cp $@ $@_shipped || cp $@_shipped $@
+       cp $@_shipped $@ || bison -l -b $* -p $(notdir $*) $<
 
 lex.%.c: %.l
-       flex -L -P$(notdir $*) -o$@ $< && cp $@ $@_shipped || cp $@_shipped $@
+       cp $@_shipped $@ || flex -L -P$(notdir $*) -o$@ $<
 
 %.hash.c: %.gperf
-       gperf < $< > $@ && cp $@ $@_shipped || cp $@_shipped $@
+       cp $@_shipped $@ || gperf < $< > $@