partial cleanup
[openwrt-10.03/.git] / rules.mk
index 417dae7de0848b6487848a0dcba8699842edc5d1..d94a818441ce8768794d28d173d40246667cea78 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -5,9 +5,23 @@ endif
 SHELL=/bin/bash
 export SHELL
 
-ifeq ($(V),)
-V=5
+ifdef V
+  ifeq ("$(origin V)", "command line")
+    KBUILD_VERBOSE = $(V)
+  endif
 endif
+ifndef KBUILD_VERBOSE
+  KBUILD_VERBOSE = 0
+endif
+
+ifneq ($(KBUILD_VERBOSE),0)
+  quiet =
+  Q =
+else
+  quiet=quiet_
+  Q = @
+endif
+
 
 CP=cp -fpR
 MAKE1=make