add BSDmakefile as a wrapper which calls gmake
[openwrt-10.03/.git] / rules.mk
index f0d21a279759e12840cb85ab5089080bd90baa87..8e5294edb3ad69ccbd3b218922a0449c368b8995 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -8,8 +8,7 @@
 -include $(TOPDIR)/.config
 include $(TOPDIR)/include/verbose.mk
 
-export SHELL=/bin/bash
-
+export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"'  --
 ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
 TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
 WGET:=$(strip $(subst ",, $(CONFIG_WGET)))
@@ -60,25 +59,10 @@ CP:=cp -fpR
 
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
-  export CCACHE_DIR=$(TOPDIR)/ccache_$(ARCH)
+  export CCACHE_DIR=$(STAGING_DIR)/ccache
   TARGET_CC:= ccache $(TARGET_CC)
 endif
 
-HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-       -e 's/sparc.*/sparc/' \
-       -e 's/arm.*/arm/' \
-       -e 's/m68k.*/m68k/' \
-       -e 's/ppc/powerpc/' \
-       -e 's/v850.*/v850/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/mips-.*/mips/' \
-       -e 's/mipsel-.*/mipsel/' \
-       -e 's/cris.*/cris/' \
-       -e 's/i[3-9]86/i386/' \
-       )
-
-GNU_HOST_NAME:=$(shell $(HOSTCC) -dumpmachine)
-
 TARGET_CONFIGURE_OPTS:= \
   AR=$(TARGET_CROSS)ar \
   AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \
@@ -106,7 +90,7 @@ IPKG:= \
 
 # invoke ipkg-build with some default options
 IPKG_BUILD:= \
-  ipkg-build -c -o root -g root
+  ipkg-build -c -o 0 -g 0
 
 ifeq ($(CONFIG_ENABLE_LOCALE),true)
   DISABLE_NLS:=